DirectX 诊断工具

DirectX 诊断工具

Microsoft® DirectX® 诊断工具文档包括以下主题：

  • 关于 DirectX 诊断工具
  • 注意事项
  • 测试 DirectX 组件
  • 覆盖默认行为


关于 DirectX 诊断工具

Microsoft® DirectX® 诊断工具用于向用户提供系统中 DirectX 应用程序编程接口 (API) 组件和驱动程序的信息。它还能够测试声音和图形输出以及 Microsoft DirectPlay® 服务提供程序。同时，还可以用于禁用某些硬件加速功能。

可以使用此诊断工具收集信息，以便在拨打支持电话时提供给相关技术人员，还可以保存通过该工具收集到的信息并将其粘贴到电子邮件中。

信息分多页显示，通过以下几种方法可以翻页：

  • 单击选项卡。
  • 单击“下一页”按钮。
  • 当输入焦点集中在某个选项卡上时，按向左键或向右键。

也可以单击“保存所有信息”按钮将所有信息保存到文本文件。

注意 某些信息（如显卡内存大小）可能是近似值。


注意事项

如果运行 Microsoft® DirectX® 应用程序时出现问题，DirectX 诊断工具可以帮助您找出产生问题的根源。下面是一些需要注意的问题：

  • DirectX 组件版本错误。在“DirectX 文件”页的“说明”部分，查找关于 Beta 文件和调试文件的警告。Beta 文件是早期测试版本，请不要与商用程序一起安装。调试版本一般用于程序开发，不要和最终产品一同安装，否则，将大大降低应用程序的运行速度，使其远远低于在组件零售版下的运行速度。
  • 缺少硬件加速。如果没有 Microsoft DirectDraw® 或 Direct3D® 硬件加速，有些程序运行速度很慢，甚至无法运行。在“显示”页的“DirectX 功能”下，查看 DirectDraw、Direct3D 或 AGP Texture 是否标记为“没有加速”。如果标记为“没有加速”，请考虑硬件升级。
  • 设备未连接。如果游戏杆或其它输入设备没有响应，可能是因为安装不正确。请确认 DirectX 诊断工具的“输入”页中是否已包含该设备。如果不包含，请通过“控制面板”添加该设备。
  • 未经认证的驱动程序。未经认证的驱动程序尚未由 Microsoft 与最新版本的 DirectX 进行完全兼容性测试。这些驱动程序列在相应的组件页中。


测试 DirectX 组件

可以在任何与系统相连的监视器上测试 Microsoft® DirectDraw® 和 Direct3D®。也可以在任何波形输出设备上测试 DirectSound®，在任何音频端口上测试 DirectMusic®。

测试 DirectX 的功能：单击相应页面上的“测试”按钮，阅读显示的任何信息，监视或监听测试过程，并让测试过程一直延续下去，直到出现提示信息，询问测试是否成功。如果回答“否”，将不再进行测试。

对于 DirectMusic，只需进行一次简单的测试。如果您对这段音乐的正确播放感到满意，或者虽然没有正确播放但您也觉得可以，单击“确定”。

可以在任何可用的服务提供程序中测试 Microsoft DirectPlay® 的功能。

procedure arrow 测试 DirectPlay

  1. 在“网络”页，单击“测试 DirectPlay”。在“DirectPlay 测试”对话框中，键入用户名并选择一个服务提供程序。选择“创建新会话”，然后单击“确定”。如果选择了调制解调器连接，请在“调制解调器连接”对话框中单击“应答”，将调制解调器置为自动应答模式。
  2. 现在，请在另一台计算机上运行 Microsoft DirectX® 诊断工具，该计算机应能和第一台计算机建立所选的连接。单击“测试 DirectPlay”，键入另一个用户名，选择相同的服务提供程序，单击“加入现有会话”按钮，然后单击“确定”。

    3. 对于某些类型的连接，可能要求提供更多的信息，例如电话号码。对于局域网的 TCP/IP 连接，可以让此文本框为空。

  3. 在第二台计算机上，“会话列表”包含在第一台计算机上创建的会话的名称，选择该名称，然后单击“确定”。
  4. 两台计算机现在都应显示聊天对话框。在一台计算机的输入框中键入一条消息，然后单击“发送”。该消息应该显示在两台计算机聊天对话框的滚动区中。


覆盖默认行为

在“声音”页，可以通过移动滑杆设置不同的硬件加速级别。该级别在关闭 Microsoft® DirectX® 诊断工具后仍然有效。

注意 该特性在 Microsoft Windows® 95 上无效。

可以禁用 DirectDraw® 或 Direct3D® 硬件加速（如果有加速功能的话）。为此，转到每个显示设备的“显示”页中，单击“禁用”按钮。禁用硬件加速之后，尽管关闭 DirectX 诊断工具，硬件加速功能对任何应用程序都无效。要重新启用硬件加速，请单击相应“显示”页上的“启用”按钮。

注意 禁用 DirectDraw 加速将同时禁用 Direct3D 加速。

也可以覆盖由 DirectDraw 全屏应用程序设置的监视器刷新频率。只有在应用程序出现显示问题，并确认该应用程序设置了无效的刷新频率时，才能这么做。

procedure arrow 设置覆盖刷新频率

  1. 在“其他帮助”页上，单击“覆盖”按钮。
  2. 在“覆盖 DirectDraw 刷新行为”对话框，选择编辑框并为监视器输入有效的刷新频率。

    3. 此时，“覆盖值”选项按钮将被自动选中。

  3. 单击“确定”。

procedure arrow 取消覆盖刷新频率，并允许 DirectDraw 应用程序自行设置刷新频率

  1. 在“其他帮助”页上，单击“覆盖”按钮。
  2. 在“覆盖 DirectDraw 刷新行为”对话框，选择“默认值”选项按钮，然后单击“确定”。


未找到主题

没有找到匹配的主题。下面列出了可能的原因和解决办法：

  • 包含目标主题的文件 (.chm) 不在预期的位置。

    • 解决办法：重新运行 MSDN 库安装程序。

  • 包含当前主题或目标主题的文件 (.chm) 已过期，链接不再有效。

    • 解决办法：安装最新版本的 MSDN 库。

  • MSDN 库 CD 没有放到 CD-ROM 驱动器中。

    • 解决办法：将 MSDN 库 CD 插入 CD-ROM 驱动器。